Jump to content
Sign in to follow this  
Guest John1390423675

Country Field - No Options & Blank

Recommended Posts

Guest John1390423675

Hello,

 

I installed the demo info for JomEstate just to get things going. When I opened the property "Exclusive Whole of top floor Penthouse" and hit save the "Country" field is now blank on the front page. The Country and State fields are running into each other as well. Here's a link to the site:

When trying to choose the country from the dropdown, in the admin section of properties, is just shows ---any---

 

I tried going into the Address section and I added a Country, region, District, City and Street to see if that would fix the issue, unfortunately no luck.

 

I also, looked in the Attributes section...there is no field for Country. The State, District and Postcode fields are there. I hope someone else has had this issue as I am not able to figure this out.

 

thanks

Share this post


Link to post
Share on other sites
Guest sue@spbsales.com

I am receiving the same issue and today I am searching for a fix. I wanted to find a solution without having to open a ticket. Did you get anywhere with this. I have clicked on your link and still see the same issue so I'm guessing not....

 

Thanks.

Share this post


Link to post
Share on other sites
Guest Kenn

It looks like you have been editing the _detailed.tpl.php template file, I like the layout you've achieved.Have you selected under the configuration options > forms show or hide country. I found I have to select show or all of the address fields don't show under the add new property form.This problem of the field appearing blank appears to be because the address hasn't been entered when the property was uploaded. I think its due to line 76span class="detailed_address">{if $data->ad_address}{$data->ad_address}{else}{''}{/if}

I think the <--EMPTY SPAN--> is the reason it's calling no data but its still calling the 'country' heading.Hope this might be useful.

Share this post


Link to post
Share on other sites
Guest sue@spbsales.com

VERY helpful !! Thank you.

 

I have removed that line altogether as I don't want to see the Country field under details anyway.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×